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Welcome to the Vision for MICROS Opera XL Exercise booklet.

Course Prerequisites

The Vision XL Exercises for MICROS Opera Training Guide is designed to help you 
become familiar with the use of the Vision XL tool for reporting over MICROS Opera. The 
training and familiarization process is based on completion of the range of exercises 
included in this guide. The exercises contained herein would typically be completed as 
part of a formal training course aided by a qualified instructor, but are designed so that  
individual self-paced training can be achieved.

Each chapter of exercises is based on the corresponding chapter in the Vision XL 
Training Guide. After reviewing the information in that guide – with your instructor or 
independently – you can proceed with completion of the related exercises.

It is assumed you are familiar with MICROS Opera and Microsoft Excel.
These exercises are designed for users of MICROS Opera 3.X, 4.X and 5.X. The exercises have 
been compiled based on the MICROS Opera 3.x demonstration database. It is highly 
recommended that you have access to this database to ensure that your exercise results match 
those expected. A previous version demonstration database may also be used, but results may 
differ slightly from those shown in this guide.
If you will be training on a MICROS-Fidelio V6 or V7 demonstration database, exercises are 
available tailored to that version.
If your organization wishes to complete the training exercises on corporate databases, please 
consult your instructor well in advance of the training sessions, as extra planning and sessions may 
be required.

During the exercises you should connect to Vision for MICROS as the user with full  
reporting rights to ensure that you receive the desired results in training exercises. Your  
instructor will provide initial assistance with connections as required.
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Introductory Exercises

Exercise 1.1:  Finding Tables & Fields in MICROS Opera
In this exercise we will focus on how the MICROS Opera datalink is structured to enable you to find 
the field or table you are looking for when reporting in Vision XL. We will also cover the different 
methods that can be used to find tables for your reports.

1. Create a new Excel workbook and save the workbook as Train_xx.xls, where xx is your 
initials. Alternatively, you might use the Opera_Train_XX.xls provided as it has all the 
worksheets prepared.

2. Rename the first worksheet in the workbook as EX1.1. 
(Hint: You can easily rename the worksheet by double clicking the tab at the base of the 
worksheet, entering the new name and hitting the Enter key).

3. Click in cell A1 on the worksheet.

4. From the Vision/Q&A XL menu select the Detail Report option. At this point the Detail Report 
Query Definition Form is displayed.

5. There are 3 Tabs on the Query Definition Form. The Report Definition tab, the Report Style 
tab and the Options tab.

6. Near the top of the window you will see a Product filter. The Product filter defines the Product 
database from which we will extract information for the current report. Initially the Product may 
be set to Vision for a new installation of the software – i.e. if you have not used Vision before.

7. Set the Product filter to MICROS-Fidelio Opera by double clicking the Product Filter line in 
the window. The Product filter lookup will appear, listing all of the Products available for 
reporting. Select the MICROS-Fidelio Opera Product from the list and click OK.
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Note: After you have run a report using the MICROS-Fidelio Opera Product, it will be set as the 
default Product for Vision reports until another Product is chosen.

Finding a Table in the Table Tree

With the Product Filter set for the report, we can choose the Table for the report. The Table 
determines which application area of MICROS-Fidelio Opera our report will be based upon.

1. Open the Table Tree by double clicking the Table filter. The Table Tree is displayed.

2. The Table Tree contains all of the MICROS-Fidelio Opera tables, categorized into groups 
according to the application that they are part of in MICROS-Fidelio Opera. The different Table 
Groups approximately equate to the menu groups that one might find on the MICROS-Fidelio 
Opera application main menu screen.

In this part of the exercise we will explore the different ways of finding tables. 

Finding a table by navigating to the associated Table Group

We may want to use Reservations table.

1. If we peruse the list of Table Groups, we will come across the Reservations group. 

2. Click the ‘+’ sign adjacent to the Reservations group. The group is expanded, displaying 
tables and sub-groups within it. In the case of the Reservations table, it is listed at the top of 
the Reservations group.

Note that the Reservations table has a table code preceding it of ‘RSV’. Throughout this 
guide you will see Vision for MICROS Opera tables referred to with their table code and 
name separated by a slash. E.g. The Reservations table will be referred to as RSV / 
Reservations.

Searching for a Table by Name
We may be wanting to use a table, say the Financial Transactions table, for a report but we are 
not sure of the Table Group in which to find the table.

1. In the Table Tree window, click the Find button and the Find dialog box will appear.

2. Enter Financial (Please note this is case sensitive) into the text box in the dialog and click 
OK. Vision will search through the Table Tree and find the next matching item. In this case it is 
the Payments & Accounts Group, which at a glance does not contain the FTX/ Financial 
Transactions table. Click the Find button again and OK a second time and it will find the next 
entry, FTX Financial Transactions in the Transactions sub group
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Searching for a Table by Table Code

As we have seen, all tables have a unique code. We may wish to search for a table using its code, 
if we know it.

1. If we want to find the BLK / Allotments & Block Bookings table for example we can click on 
the Find button enter BLK and click OK. Vision will search the Table Tree and find the 
matching table code, giving us the location of the Allotments & Block Bookings table. Note that 
this code search is not case sensitive.

Using Favourites to make finding regularly used tables easier

As we begin to use Vision there may be areas in Opera, perhaps closely related to our job function, 
from which we extract information regularly. These tables can be added into a Favourites list that 
will give us quick and easy access to them, negating the need to search the Table Tree.
An example may be the EVT / Events table.

1. Move towards the bottom of the Table Tree.

2. Open the Sales & Catering table group by clicking the ‘+’ symbol adjacent to the group.

3. Click on the EVT / Events table.

4. Click the Favourites button and select the Add option.
Note that a Favourites Table Group is created at the top of the Table Tree, making it easy to 
quickly access your favourite tables.

5. Click Cancel to exit the Table Tree and Cancel to exit the Detail Report Query Definition 
window.

Searching for a Column or Field by Name

The datalink contains thousands of fields or columns from Opera. Navigating through this especially 
when table joins are used, can be confusing. To this end, from Vision 6.3.1 there is a search 
function for fields, keeping in mind that field labels in Opera are user-definable and may differ to 
that of the datalink.

1. Select the RSV Reservations table. This is your base reporting table for this Detailed Report.

2. With your cursor on an item in the Selection List, right click. The options available allow you to 
select the highlighted item as a filter or for output. Collapse All allows you to collapse all 
expanded items.  Expand and Show Selected Items show where the highlighted Output item 
appears in the expanded Selection List.

3. Find (or F5) requires a field or column name or partial name. Type Tax Type in the box and 
press Enter. The serduct will then be searched from top down (2 levels / joins) for any 
Selection List item with Tax Type included in it. F3 searches for the next entry.
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Exercises for Section 2: Detail Report

A Detail Report provides a detailed listing from your database into an Excel worksheet.  There is 
one row in Excel for each record in your database. Query & Analysis XL includes a sum total of 
numeric results at the end of the report.

You can set a transaction limit in Query & Analysis Setup to limit the number of transactions 
extracted at any one time. When the transactions extracted reach that number, a message appears 
notifying you of the limit and the first cell in the extraction is coloured blue with a note of the limit 
attached. You must reset the limit in Query & Analysis Setup to view further transactions.

Exercise 2.1:  Defining a Detailed Report
In this exercise we will create a listing of Guests departing on today’s date, it will be filtered by 
Departure Date and sorted by the room Number and Arrival Date.

1. Insert a new Excel worksheet called EX2.1.

2. In cell A1 open the Detail Report definition form.

3. Set the Product filter to MICROS Opera, Table filter to Reservations > RSV 
Reservations, the Resort filter to a Resort within your database, and Report Start and End 
Date filters to <ALL>.

4. Add RSV Reservations<Dates & Times<Departure Date to the Filter window and filter 
by todays date.Transfer the following to the output window:

Room Details>Room 

Guest Details & Profiles>Guest Last Name

Guest Details & Profiles>Adults

Dates & Times>Arrival Date

Dates & Times>Departure Date

 Rates>Effective Rate Amount

Payments & Accounts>Balance

5. Sort by Room and then Arrival.

6. Set the Report Style to List 2.

7. Save an Internal Definition as EX2.1.

8. Click OK to run the report.

9. Rename the worksheet to EX2.1 and then save the workbook.  
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Exercise 2.2:  Modifying a Previously Saved Internal Definition
In the exercise we will open the previously saved Internal Definition and add an External Definition 
formula.

1. Move to a new worksheet and rename it to EX2.2.

2. In cell A1 open the Detail Report Definition form.

3. Use the Load Definition button to load the Internal Definition EX2.1 saved in the previous 
exercise.

4. In the External Definition filed type Reservations2 and then click on the assist button to 
browse to your desktop. Change the Internal Definition to EX2.2. 

5. Click OK to run the report and then save the Excel workbook.
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6. If you now look at your desktop there will be a file called Reservations2.atb. You can share 
this file with other Vision users as a report definition, or use it as a backup.

Exercise 2.3:  Defining a Detailed Report
In this exercise we will create a Detail Report showing the Reservation made yesterday.

1. Insert a new Excel worksheet called EX2.3.

2. In cell A1 open the Detail Report definition form.

3. Set the Product filter to MICROS Opera, Table filter to 
Reservations > RSV Reservations, the Resort filter to a Resort within your database, and 
Report Start and End Date filters to <ALL>.

4. Add RSV Reservations>Administration>Insert Date to the Filter 
window and filter by yesterdays date. Transfer the following to the output window:

Administration>Insert User

Guest Details & Profiles>Guest Last Name

Dates & Times>Arrival Date

Dates & Times>Departure Date

Rates>Rate Code

Rates>Effective Rate Amount

Save an Internal Definition as EX2.3.

2. Click OK to run the report.

Exercise 2.4: Filters - Wildcard Filters – Part 1
In this exercise we will use a wildcard filter to find any records starting with the letter M from Guest 
Profiles. Commonly used wildcards in Windows are * and ?.

1. Move to a new sheet and rename the worksheet EX2.4.

2. Click in cell A1 and then open the Detail Report definition form.

3. Set the Table filter to Profiles > GU Individual Profiles.

4. Set Resort to EU (or yours if using your database).
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5. Leave Report Start and End Date filters at <ALL>

6. Output the data items:

Names & Greetings > Last Name

Names & Greetings > First Name

Contact Details > City

Contact Details > Country Name

7. Drag the item Country (Code) to the Filter window and set it to From CA to CA.

8. Drag the data item Last Name to the Filter window.

9. In the Filter window select Last Name and enter “M%” in the Filter From field.

10. Save the Internal Definition as Individual Profiles and run the report.

11. Save the Excel Workbook.

Exercise 2.5: Wildcard Filters – Part 2
During the exercise we will combine wildcard filters to find any records where the second character 
is an “a”.

Move to a new worksheet and name it EX2.5.

1. In cell A1 open the Detail Report definition form.

2. Set the Table filter to Profiles > GU Individual Profiles. 

3. Set Resort to <ALL> (or yours if using your database).

4. Output the data items:

a. Names & Greetings > Last Name

b. Names & Greetings > First Name
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c. Contact Details > City

d. Contact Details > Country Name

5. Add City as a filter and set the filter to _a%.  The _ Underscore means “anything as the 
first letter, followed by an “a”.  The %, means any combination or number of letters 
following the “a”.

6. Save the Internal Definition as Individual Profiles2.

7. Click OK to run the report and then save the workbook. 

Exercise 2.6: Non-Contiguous Lookup Filters
In earlier exercises we defined reports using simple Lookup List filters. I.e. Filter values were 
selected from lookup lists either by double clicking the filter item or clicking the filter item followed 
by the Data Filter Assist button. In the examples only one filter item at a time, or a contiguous 
range could be selected.
This exercise shows how filters can be defined using non-contiguous ranges combined with 
contiguous ranges and individual selections. We will create a report that displays a list of 
Financial Transactions from OPERA.

1. Insert a new worksheet into the Excel workbook and rename it EX2.6.

7. Click in cell B2.

8. From the Vision menu, select Detail Report. A blank Detail Report Query Definition form is 
displayed.

9. Find the FTX / Financial Transactions Table in the Table Tree. Select the table for the 
report.

10. Set the Resort filter to EU or a Resort within the database you are working on.

11. Set the Report Start and Report End Date filters to <ALL>. 
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12. Please note – if using a database/schema other than the demo, please set a known small date 
range by adding the Transaction Date to the filter window and defining a 1 day period. The 
Financial Transaction table in a live schema can be huge.

13. Add the Transaction Code field from the Transaction Categorizations group of the Selection 
List to the Filter window.

14. Double-click the Transaction Code filter, displaying the lookup list for Status. All Transaction 
Codes and Descriptions are listed, in numerical order – the default for Vision lookup lists. The 
group of items that we wish to filter is not in a contiguous, alphabetical order range. The filter 
items are in a non-contiguous order.

15. Hold down the Ctrl Key on the keyboard and click on the following Transaction Code values in 
the list:
Lobby Bar Beverage & Lobby bar Beverage
Room Service Food & Room Service Beverage
Restaurant Food & Restaurant Beverage
Minibar Food, Beverage & Miscellaneous

16. Click OK. The filter value is set to the non-contiguous range of values in the Filter window.
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17. Add the following Fields from the Selection List to the Output List.
Transaction Categorizations > Transaction Code
Transaction Categorizations > Transaction Codes > Description
Transaction No.      Reservation > RSV 
Reservations (Original) > Guest Details&Profile > Guest Last Name
Room Details > Room Number

Under Reservations there are 5 entries. The first (Charged To) refers to the Reservation 
that has the transaction at the time the report is run, taking into account the end result  
of Routing. The second (Original) will use the originator of the transaction in a routed 
scenario, irrespective of where the transaction ends up. The third option looks at 
Transaction Routing Instructions in detail i.e. where the transaction was posted to,  
routed to or routed from including room to room, window to window and guest to 
company. The fourth and fifth options look at details of the profiles “paying” the folio,  
account or window whether this is an individual, company, agent or group master.

18. Transaction Amounts > Net Amount

19. Transaction Amounts > Quantity

20. Sort the report output by Room Number then Guest Last Name.

21. Set the Internal Definition name for the report definition to EX2.6.

22. Click OK to run the report.

The transactions matching the report filters – in particular the non-contiguous Transaction Code 
filter are listed.

Exercise 2.7: Cell Reference Filters and Automatic Filter Lookups
In previous report examples, filters have been defined in the report with criteria values for the filters 
selected directly from the Lookup List for the filter items. In some exercises criteria have also been 
entered directly into the Excel worksheet and linked back to the filter items in the report definition.
When this has been done we can use Automatic Filter Lookups to perform lookups in the Excel 
sheet.

1. Insert a new worksheet into the Excel workbook and rename it to EX2.7.

23. Enter the following text in the specified cells.
Date From A2
Date To A3

Trans Code A4
Trans Group A5
The date for yesterday B2
The date for yesterday B3

1000 B4
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<ALL> B5
24. Click in cell C6.

25. From the Vision menu, select the Detail Report option. A blank Detail Report Query Definition 
form will be displayed.

26. Retrieve the Internal Definition EX2.6 (created in the previous exercise).

27. On the Options tab change the Internal Definition name to EX2.7.

28. Add Transaction Code Group to the Filter window.

29. On the Definition tab single-click on the Report Start Date filter item in the Filter Window and 
press the Backspace Key on the keyboard to clear the current filter criteria. The Filter From 
is now shown above the Filter window and is empty.

30. Click in the Filter From field.

31. Click on cell B2 in the Excel worksheet. The Filter From field is populated with the cell 
reference to cell B2 ($B$2).

32. Repeat for the Report End Date filter.

33. Click on cell B3 in the Excel worksheet. The Filter From field is populated with the cell 
reference to cell B3 ($B$3).

34. Repeat this for both Transaction Code and Transaction Group but this time, both Filter From 
and Filter To must be entered with the same value i.e. $B$4 for Transaction Code as per 
below.
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The filter criteria are now cell references. They are initially absolute references. The cell references 
can be changed to relative references by clicking in the Filter From and / or Filter To fields as 
appropriate and pressing the F4 Key on the keyboard.

35. Click OK to run the report.

The report is extracted based on the filter criteria, now entered on the worksheet itself.

Use of Automatic Filter Lookups

When cell references are used for filters, Vision automatically creates a link between the referenced 
cell on the worksheet and the Lookup List for the filtered item. This is known as an Automatic 
Filter Lookup. 

1. Double-click on cell B4 on the worksheet. The Lookup list for Transaction Code appears 
automatically as the filter is now an Automatic Filter Lookup.

2. Click the Clear Down button (just below the Refresh button) in the Lookup list dialog.

3. Double click the 1000 value and then double click the 1350 value. The values are populated 
into the From and To fields respectively to filter all Room type revenue.

4. Click OK to return the new filter values to the worksheet.

5. From the Vision menu, click Recalculate and then click the Worksheet option in the sub-
menu. The report will be recalculated (re-run) using the new filter values.

Automatic Filter Lookups can be used to set single, contiguous range and non-contiguous range 
filters.

Exercises for Section 3: Summary Report

Exercise 3.1:  Defining a Summary Report
In this exercise we will extract data values for market segments summarized by Market Code and 
Market Code Description. Following this we will insert Automatic Filter Lookups where a Cell 
Reference is associated with a report filter.

1. Move to a new worksheet and rename it EX3.1.

36. Select cell C1 and open the Summary Report definition form.

37. Set the Table filter to Statistics > RL Reservation Daily Statistics.

38. Set the Resort filter to ALL or a single Resort within the database you are reporting from.

39. Set the Report Start and End Date filters to reflect June 1 – 21 2004.

Vision for MICROS Opera XL Exercises 14



40. Output the data items Market (Code), Market (Description), Room Nights/Stay Rooms and 
Room Revenue.

41. Select the AutoFormat Classic 2.

42. Save the Internal Definition as EX3.1.

43. Run the report.

44. In Cell A1 type Property, in Cell A2 type Start Date and in A3, End Date.

45. In Cell B1 type EU (Demo Property Name), in B2 type 01/06/2004 (June 1, 2004) and in B3, 
21/06/2004 (June 21, 2004).

46. Open the Summary Report definition in Cell C1 and in the Filter Window, reference B1 for the 
Resort filter, Add Business Date to the filter window and reference to B2 for the start and B3 
for the End Date.

47. Click on OK to run the report.

48. In order to change the filters now at any time you can double click each referenced cell and 
select the filter you wish to use.

Exercise 3.2:  Summary Level
In this exercise we will modify the Internal Definition saved in the previous exercise and additionally 
summarize it by the Source. The Source will not have an Extract Mode and therefore the output will 
contain one row for each combination of Market, Main Market and Source.

1. Open the report you created in the previous exercise. 

49. Add Source (Code) to the output above Room Nights.

50. Change the Internal Definition name to EX3.2 and then click OK to run the data report.
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Exercise 3.3:  User Defined Outputs – Part 1
In this exercise we will create a User Defined Output to join the Market Code and Description and to 
calculate the Average Rate by dividing Room Revenue by Room Nights.  

1. Move to a new worksheet and name it EX3.3.

2. Move to cell A1 and then open the Summary Report definition form.

3. Set the Table filter to Statistics > ME Market Statistics Daily.

4. Filter as follows:  

5. Resort is <ALL>

6. Business Date for June 1, 2004 to June 21, 2004

7. Output the data items Market (Code), Market (Description), Total Room Revenue, and 
Definite Rooms.

8. Right click on the Market(Code) item in the Output area and select Combinations from the 
menu.  Check both ME\Market(Code) and ME\Market(Description) and then click OK.  This 
will combine the two fields into one User Defined Output (UDO) field.

9. Click on the UDO you just created and change the Description to Market.

51. To create the UDO for Average Rate, click the User Defined Output button to open the User 
Defined Output form.  

52. Enter Average Rate as the description.

53. Change the format to Number.
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54. In the Formula area, enter the formula {ME\Total Room Revenue}/{ME\Definite Rooms}. 
Remember to drag or double-click the items from the Selection List.

55. Enter XXXX in the Default value if error field. Note that any formula where it is 0 divided by 
will return XXXX. Should you wish to avoid this then the formula should be an “if” statement.

56. Also note that UDOs can be exported and a library built of them over time that can be 
imported for use. Click on Export and in the filename type “Average Rate”. This will then save 
the UDO to your desktop with a file extension of .UDO.

57. Sort by Room Revenue.

58. Save the Internal Definition as EX3.3 and then run the report.

With “IF” statement UDO

Exercise 3.4:  User Defined Outputs - Part 2
In this exercise we will  create a Summary Report  with multiple User Defined Outputs that will 
calculate the revenue generated by Room, Food, and Other as a percentage of the Total.

1. Move to a new worksheet and rename it EX3.4

2. Move to cell A1 and open the Summary Report Definition form

3. Set the Table filter to Statistics > RL Reservation Daily Statistics.

4. Apply a filter on the Business Date for 1 week
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5. Output the Market (Code), Market (Description), Room Revenue, Food Revenue, Other 
Revenue and Total Revenue.

6. Create the below User Defined Output that will calculate the % of Room Revenue of the 
Total

7. Click OK and then Right Click on the Room % item in the Output Window and select Copy. 
You will notice another UDO appear at the bottom in the Output window.  Modify this UDO 
to calculate the Food % and modify the description to Food %, then click OK.  Move this 
UDO to appear after the Food Revenue figure.

8. Right click on the Food % UDO and select copy, modify the new UDO to calculate the 
Other Revenue as a percentage of the total and rename it to Other %.  Move this item to 
appear after the Other Revenue figure.

9. Save the Internal Definition as EX3.4 and then run the report
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Exercises for Section 4: Data Link

Exercise 4.1:  Defining a Data Link Report
In this exercise we will extract Guest Profile information with reference to Name and Stay details.

59. Move to a new worksheet and name it EX4.1.

60. Type the following labels in the worksheet: 

61. Move to cell D2 and open the Data Link definition form.

62. Set the Table filter to Reservations > RSV Reservations.

63. Filter as follows:  Resort to <ALL>, for Reservation Name ID type in <ALL> and Report 
Start and End Dates to <ALL>

64. Place the cursor in the filter field for Confirmation No., and then click cell C2 in the worksheet 
to select the cell reference as the filter.  Press F4 to change the cell reference from relative 
(C2) to absolute ($C$2).

65. Output the data item Guest Last Name.  

66. Add the following data items to the output and then click the corresponding cell address:

e. Arrival Date C3

f. Departure Date C4

g. Booked Room Category Label C5

h. Room C6

i. Adults E2

67. Run the report.

68. Change the Confirmation No. in cell C2 to 12020 and then recalculate the worksheet. 

69. Alternatively you can use the Automatic Filter Lookup by double-clicking cell C2 and a list of 
all Confirmation numbers will appear in numeric order. It is recommended that you take care 
with this as many lists in Opera are large.
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Exercises for Section 5: Summary Link

Exercise 5.1:  Summary Links
In this exercise we will extract a Market Segment report for the different Source codes for a month. 
This is a “cross reference” type report based on 2 axes.

1. Move to a new worksheet and rename it EX5.1.

2. Starting in cell A3 complete a Summary Report using the table Marketing > Markets 
outputting Market (Code) and Description with no Table names, Data Item names or totals 
(on the Report Style Tab).

3. On the Options tab ensure that Create Definition Formula equals N. This will mean that 
once extracted, there is no formula to re-extract each time the worksheet is recalculated.

4. Starting in cell C1 complete a Summary Report using the table Statistics > Reservation 
Summary outputting Source (Code) and Source (Description) with no Table names, Data 
Item names or Totals. Ensure this data is set to extract Across (on the Options Tab). Set the 
Event Type filter to <ALL>, and the Create Definition Formula to equal N.

5. In cell B1 type 01/06/2004 (June 1, 2004) and in cell B2 type 21/06/2004 (June 21, 2004) and 
make these references absolute.

6. In cell C3, open the Summary Link definition form.

7. Set the Table filter to Statistics > RL Reservation Daily Statistics.

8. Set the Resort filter to EU.

9. Add Market (Code) as a filter and set the filter to cell A3. Make the cell absolute by column.

10. Add Source (Code) as a filter and set the filter to cell C1. Make the cell absolute by row.

11. Set the Business Date From filter to cell B1 and Business Date to to cell B2.

12. Output Room Details > Room Nights/Stay Rooms. 

13. Run the report.

14. Copy the cell C3 down the rows to your last Market Code. Then copy across to the column 
with your last Source Code.

15. In cell B13 enter Totals.

16. In cell C13, create a sum formula for cells all the Market Codes. Copy from column C across 
to the last column for Source Codes

17. Recalculate the worksheet.
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Exercise 5.2:  Format Tables
In this exercise we will add a Format Table to the Totals column of the previous report in order to 
highlight certain user defined conditions.  

1. Select cell C14.

70. Open the Format Tables form (Vision Menu > Format Tables).

71. Enter C13 in the Value Cell field.  

72. Click the Set as Default button.  

73. Open the Format Table form by clicking the Format Table assist button.  Enter the settings 
displayed in the screen below:

74. Select a yellow background and bold font for the values 0 to 50.

75. Select a blue background and bold font for the values 51 to 150.

76. Select a green background and bold font for the values 151 to 250.

77. Select a pink background and bold font for the values 251 to 99999.

78. Click the Save button and then close the form.

79. Copy cell C14 to cells D14 to K14.

80. Recalculate the worksheet.
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Exercise 5.3:  Summary Links

In this exercise we will create a report using summary links giving us our future rooms on the books 
by Room Type Label.

1. Move to a new worksheet and rename it EX5.3

2. Move to Cell B6 and create a Summary Report using the table Rooms & Housekeeping > 
RM / Rooms outputting the Room Type Label, Short Description and Filter by a valid 
Resort for your database. Then output the Room Number and set the extraction type to 
Count, with no Table names or Data Item names.

3. Type in the date for Tomorrow in cell F4, the date for the day after tomorrow in G4, and so 
on until you have a date populated in column O.  This should give us the next 10 days.

4. Move to cell F6 and open the Summary Link Definition form.

5. Set the table filter to Statistics > RSM Reservation Summary.

6. Set the Resort to EU or a resort within the database you are reporting from, set the Event 
Type filter to <ALL>

7. Add a Filter to exclude the Psuedo ? Rooms, and add Reservation Inventory Type to the 
Filter window and set it to D.

8. Add the Label field from Room Details >  RMC Room Types to the filter window and set it 
to cell B6, make sure you populate the to value also.

9. Add the Considered Date to the filter window and set it to F4, again making sure you 
populate the to value.

10. Output Room Details > Number of Rooms

11. Copy cell F6 down and across the report and then recalculate to run the summary link for 
all room labels and dates within the workbook.
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Exercises for Section 6: Query Templates

Exercise 6.1:  Creating a Template
In previous exercises, we re-used reports, using the Internal Definition function to save copies 
separately. That method is only applicable if a report is being re-used within one Excel workbook.
If a report needs to be shared across multiple Excel workbooks, across Vision applications and 
perhaps by multiple users, then the report definition can be saved in a Query Template.

1. Open the Summary Report Query Definition form from Exercise 3.3

2. Right click anywhere within the Filter window of the Definition Form. A popup menu is 
displayed giving various options.

3. Click the Save Template option. The Save Template dialog appears.

The Save Template contains folders in which Vision Query templates can be saved. All templates 
are saved in the Vision Centralized Database, making them accessible from any location. 
Templates saved in the Library folder are accessible to all users. Templates saved in your own 
user folder are only accessible by you.
As well as being able to share templates between Excel workbooks, templates created in Excel can 
retrieved and used in Vision Executive and Vision Word, and vice versa in both cases. Note that 
some formatting in reports will not be retained when sharing templates between Vision products.

1. Select the Library folder.

81. Click the Save In button. The Save In dialog appears.

82. Enter the details in the window as below, replacing the Code field with your initials. Note that 
the Code is a unique identifier for a template.

83. Click the Save button to save the template. You are now returned to the Summary Report 
Query Definition for Exercise 3.3.
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84. Click Cancel.

The template will now be available for re-use from within this workbook, other Excel workbooks and 
from other Vision products.

Exercise 6.2: Using a Query Template to create a Report
85. Insert a new worksheet into the Excel workbook and rename the worksheet EX6.2.

86. Click in cell A1.

87. From the Vision menu, select Query Templates. The Open Template dialog appears.

88. Click the Library folder. 

89. In the displayed list of Templates, click the template you saved in Exercise 9.1. 

90. Click Open. The report definition is retrieved from the template and displayed in a new Detail 
Report Query Definition window.

91. Click on Options.

92. Change the Internal Definition name from the default to EX9.2.

93. Click OK to run the report.

The report is displayed. It has been created using an existing template as a basis. Although the 
exercise has not called for changes, changes could have been made to this report without affecting 
the template or other reports.
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Exercises for Section 7: Combining Vision XL Functions

Exercise 7.1:  Combining Data Link, Summary Link and Detail Report
In this exercise we will create a Data Link to output Guest details, create a Summary Link to output 
balances, and create a Detail Report to output the transaction details.

1. Move to a new worksheet and name it EX7.1.

94. Enter the following labels in the worksheet:

95. Type in a Valid Room Number in cell B5

96. From cell B4 open the Data Link/Reference File Link definition form.

97. Set the Table filter to Reservations > RSV Reservations.

98. Set Resort to a valid Resort for your database, and Reservation name ID to <ALL>.  Report 
Start & End Date set to todays date.

99. Add a filter, Room and reference cell $B$5

100. Output Guest Last Name, Arrival Date, Departure Date, Company, and VIP Status (Code).

101. Assign the remaining data items to cells as follows:

Guest Last Name B4

Arrival B6

Departure B7

Company C4

VIP Status (Code) D4

102. Click OK to run the report.

103. In cell G4 open a Summary Link.

104. Set the Table filter to Payments & Accounts > Transactions> FTX Financial Transactions.

105. Set the Resort filter to the same Resort as in point 6 above and add the filter for Room 
Number. The Report Start Date and Report End Date should reference $B$6 & $B$7 
respectively. Room Number references cell $B$5

106. Output Quantity, Revenue Amount, Guest Account Ledger Credit and Guest Account 
Ledger Debit as below and then click OK to run the report. 

107. Click cell A12 then open the Detail Report definition form
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108. Set the Table filter to Payments & Accounts > Transactions> FTX Financial Transactions.

109. Add Filter Room Number. and reference cell B5.

110. Add Filter for the Report Start Date and Report End Date and reference cells B6 to B7.

111. Output the following data items:

Transaction Date

Transaction Description

Revenue Amount

Non-Revenue Amount

Guest Account Ledger Credit

Guest Account Ledger Debit

Quantity

112. On Report Style select Auto Format Report Style and an Auto Format of Colour 2 and un-
tick the Width checkbox.

113. Save the Internal Definition as Detail Trans.

114. Click OK to run the report.

115. Change the Room Number in cell B5 to 1014 and recalculate the worksheet.

Exercises for Section 8: Macro Builder

Exercise 13.1: Creating a Macro to Run a Detail Report
In this exercise we will create a simple macro to automate a previous exercise (EX2.1).

1. At the beginning of your workbook containing Exercise 2.1 (Detail Report), insert a worksheet 
and rename it MENU.

116. Click in the worksheet, approximately where you want the macro button.
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117. Select Vision > Utilities >Macro Builder.

118. Double-click Select Range in the Steps window to add the step to the Macro Recipe window.

119. Click in the Range field, click in the worksheet containing EX2.1 then click cell A1 to define 
the range.

120. Double-click Select Current Region in the Step window to transfer it to the Macro Recipe 
window.

121. Transfer Clear Range and Run Detail Report to the Macro Recipe window.

122. Click the Filename assist button, select Yes to display the list of previously saved Internal 
Definitions.

123. Select previously saved Internal Definition EX2.1.

124. Double-click Select Range and select cell A1 on worksheet EX2.1.

125. On the Options tab in the Macro Name field, enter Guests to define the macro name that is 
saved with your workbook.

126. In the Button Name field type Extract Guests.

127. Save the Macro Builder Internal Definition as GSTS.

128. Click OK then move to the MENU worksheet to find the macro button created.

129. Click any cell in your worksheet to deactivate the button and save the workbook.

130. Click the Extract Guests button to run the macro.

Exercises for Section 9: Report Designer

Exercise 9.1: Report Designer
In this exercise we will create and format a report for Market Segment and Company Name. This 
will be done step by step, building on the initial unformatted report.

1. Move to a new worksheet and rename it EX9.1.
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2. Click cell B2 then select Summary Report.

3. Select the table Statistics > RL Reservation Daily Statistics.

4. Filter Report Start and End Dates for 01/06/2004 and 14/06/2004 (June 1 – June 14).

5. Filter Resort for EU or a valid property for the database you are reporting from.

6. Select the following data items for output in this order:

Market (Code)

Market (Description)

Linked Organisations > Company Profile > Name

Room Nights/Stay Rooms

Room Revenue

Create a User Defined Output for Average Rate

Total Revenue

131. Set Sort order by Market (Code), then add a filter to the report on Room Nights to be greater 
than 0

132. In Internal Definition enter Market Segment Summary.

133. Run the function.

134. Move to a new worksheet, rename it EX9.2 and click in cell B2.

135. Open the report definition you just created using the Load Internal Definition feature. 

136. Change the Internal Definition name to Report Designer Summary.

137. Click the Designer radio button and then click the Edit button.
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138. Select Market (Code) in the Output window and drag to cell A1. Select Item.

139. Drag the following Output data items to relevant cell and select Item:

Company Name  B1

Room Nights C1

Room Revenue D1

Exercise 9.2: Editing Columns and Formatting Cells
1. Select column A and right-click. Select Move Column Right A.

2. Select column B and right-click. Select Move Column Left B (returning the columns to their 
original place.

140. Select column E and right-click. Select Add Column E..E. Add 2 more columns.

141. Select column G and right-click. Select Delete Column G.

142. Drag the remaining data items to the following cells and select Item:

Average Rate E1

Total Revenue F1

143. Right-click on cell C1 (Room Nights) and select Format > Format Cells. Select Fixed and 
Zero decimal places.

144. Right-click on cell D1 (Room Revenue) and select Format > Format Cells. Select Currency 
and $#,##0;-$#,##0.

145. Right-click on cell E1 (Average Rate) and select Format > Format Cells. Select Currency 
and $#,##0.00;-$#,##0.00.

146. Click cell D1 and click the Format Painter button. Then click cell F1 (Total Revenue). 
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Exercise 9.3: Adding Headings and Subtotals
147. Click the Add button and select Section > Header/Subtotal.

148. Drag Market (Code) from Output window to Change of window. This defines on change of 
what will the sub total be performed. In this case every time there is a new series of Market 
Code entries there will be a sub total.

149. Click the Header check box to include a Header.

150. Leave the number of Header rows as the default, 2.

151. Select Pale Yellow to automatically format the Header to this color.

152. Select the Subtotal check box then select a format color of Pale Grey.

153. Click OK to return to the Report Designer dialog box.

Exercise 9.4: Adding Field Totals
1. Change cell A1 to Market Segment.

2. Drag Market (Description) to cell B1 and select Item:
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3. Select cells A1:B1, right-click, select Format > Format Cells and change the font to bold and 
the size to 10.

4. Type the following headings in the listed cells:

Company B2

Room Nights C2

Room Revenue D2

Average Rate E2

Total Revenue F2

154. Using the CTRL key, select cells B2, C2, D2, E2, and F2 and format the cells to be right 
justified, if not already.

155. Delete the word Subtotal from cell A6.

156. Type TOTALS in cell B6.

157. Click cell C6 then right-click and select Add > Field Total. Add a Field Totals to cell D6 and 
F6. 

158. Set the currency format to $#,##0.00;-$#,##0.00 and the font size to 11 for D6 and F6.

159. Set the format to Zero Decimal Number for C6 with font size 11.

160. Set the format to $#,##0;-$#,##0 and the font size to 11 for E6.

161. You will need to enter a formula for Average Rate as totalling the ADR will not provide an 
average. In cell E6 type =D6/C6. This will provide a correct Average Rate.

162. Select the Border tab after selecting Auto Formatting and insert a single line at the top and a 
double line at bottom for all Totals.

163. Click OK to return to Report Designer.

164. Click OK to run the report.

Vision for MICROS Opera XL Exercises 31



165. Open Report Designer Summary in Report Designer.

166. Move to row 6, subtotal section and select Expand Controls and Collapse All.

167. Click OK twice to run the report.

168. Save your workbook.

Exercise 9.5: Adding Totals and Page Headers
1. Another way that you may find convenient to open the report in Report Design mode, select 

cell B2 then select Vision > Utilities > Function Launcher.

169. Open Report Designer Summary in Report Designer.

170. Click Add and select Section > Total.

171. Change A8 to GRAND TOTAL, bold and a font of 12.

172. Increase row height for row 8 to allow for the larger font.

173. Add a Field Total in cell C8. Insert a bold line at the top and bottom of the cell. Change the 
format to Fixed with 0 decimal places and make the font bold and 12.

174. Add a Field Total in cells D8 and F8. Change the format to Currency $#,##0.00;-$#,##0.00 
and make the font bold and 12.

175. Type =(D8/C8) in cell E8. Set the format to $#,##0;-$#,##0 and make the font bold and 12.

176. Click the Add button and select Section > Page Header.

177. Select the Page Header section then increase the number of rows to 3.

178. Enter MARKET SUMMARY by COMPANY in cell A1.

179. Select cells A1:F1 and change the format to bold and 14.

180. Change the alignment to Centre Across Cells.
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181. Click OK to exit Report Designer.

182. Click OK to run the report.

183. Save your workbook.

Exercise 9.6: Report Designer – Filtered Columns
In this exercise we will create a forecast report looking at the Rooms we have on the books 
broken down by day.  We will then use the Filtered Columns functionality to break this out by 
Market Code.

1. Move to a new Worksheet and rename it EX9.6

2. Move to cell B3 and type in Date, then Occ% in C3 and Total in E3

3. Move to cell F3 and create a Summary Report from the Markets table outputting the 
Market Group (Code).  Filter by the relevant Resort for your database.  On the Report 
Style tab remove Totals and Output Data Item Names.  On the Options tab change the 
direction to Across.

4. Move to cell B4 and then select the Summary Report option

5. Set the Table filter to Statistics > RSM Reservation Summary

6. Set the Resort to EU or a resort within the database you are reporting from, set the Event 
Type filter to <ALL>

7. Add a Filter to exclude the Psuedo? Rooms, and add Reservation Inventory Type to the 
Filter window and set it to D.

8. Add Market Group (Code) to the Filter Window and set it to <ALL>
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9. Add Considered Date to the Filter Window and set it to be the next 30days

10. Output Considered Date, Resort > Rooms & Housekeeping > Number of Rooms and 
also the Number of Rooms from the Room Details section on the root of the table.  Sort 
the report by Considered Date.

11. Move onto the Report Style tab and select the Designer option and click Edit

12. Drag Considered Date to cell A1 and select item

13. Drag the 1st Number of Rooms to cell C1 and select item

14. Drag the 2nd Number of Rooms to cell D1 and select item

15. Click in cell B1 and type in the following formula =D1/C1 and format the cell to be a 
percentage

16. Move over to column E and right click and select Add Column E..E, repeat this for the 
number of Market Group Codes you have within the database you are reporting from.

17. Drag the last Number of Rooms field from the Output window to cell E1 and select item

18. Right click on column E and select Add Filter on selected Column, you will then be 
presented with the filter window where you need to cell reference the Market Group 
(Code) to F3 in Excel. 

19. Repeat steps 17 & 18 above for the number of Market Group (Codes) you have, setting the 
filtered columns to your different cells.

20. Tick the Auto size Columns tick box and click OK

21. Rename the Internal Definition to EX9.6 and click OK to run your report
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